next up previous contents index
Next: The Rulers Button: Create Up: The View Menu: Alter Previous: Layer Sequencing   Contents   Index


The Cross Section Button: Show Cross Section

The Cross Section button in the View Menu brings up a special sub-window which displays a cross sectional (side) view of the layers under an arbitrary line. After pressing the command button, the user is asked to define a line, which can be done by clicking twice or dragging. If the line covers any geometry (which may be implied by dark field layers), a sub-window showing the cross sectional view will appear. The process can be repeated. Pressing the Esc key will exit the command.

All geometry under the line will be shown, without regard to cell hierarchy.

If the Constrain angles to 45 degree multiples check box in the Editing Setup panel from the Edit Menu is checked, the angle is constrained to multiples of 45 degrees. If not checked, the angle is unconstrained, but snaps to multiples of 45 degrees when the angle is close. In either case, pressing the Ctrl key removes the constraint.

The endpoints initially do not snap to grid points. The period (`.') key toggles snapping to grid of the endpoints, when defined with the mouse or other pointing device.

The endpoints are saved in persistent storage, and the previous cross section can be repeated by pressing Enter while the command is active, even if the command terminated after the last cross section was displayed. One can experiment with different thicknesses or planarizing behavior of the layers, and easily compare cross sections from the same line, using this feature. If the current cell has changed, the stored endpoints will have no effect.

The display makes use of the three-dimensional layer sequencing database described in 12.8 to build up a three-dimensional representation of the geometry along the line. This requires that the layers are appropriately set up in the technology file. There are few defaults, and this command will not work without proper setup.

The layer thickness shown can be set with the CrossThick technology file keyword. This can be applied in the physical layer blocks of the technology file, or can be set or edited from the Tech Parameter Editor.

If CrossThick is not set, the displayed thickness will be taken from the Thickness parameter, which must be set to a nonzero value in any case. This is the physical film thickness. In cases where this is too thick or thin for convient viewing in cross-section, the CrossThick keyword can be set to provide an overriding thickness used in the display.

The layer shown in the cross section is always true polarity, showing where the material will exist on the substrate. This is the inverse of the normal drawing windows when the layer is dark field. A via, for example, which appears as a colored square in the main window, should appear as a hole in cross section, since the painted area actually represents lack of insulating material. This is a "dark field" layer.

By default, the display uses Auto Y-Scale mode, where the total displayed thickness of the layer stack is a little less than the display window height. This scaling is used for any magnification, which of course has the usual effect in the horizontal direction.

The Y-scale can be manipulated by the panel brought up from the Zoom button in the View menu of the cross-section display window. In this configuration, the Set Display Window panel has a set of controls for adjusting the Y-scale. The Auto Y-Scale check box sets whether of not the automatic scaling is used. This corresponds to the XSectNoAutoY variable.

The Y-Scale entry area allows a scale factor to be entered. In Auto Y-Scale mode, this will change the displayed layer stack height relative to the window height. Otherwise, this will be a constant linear scale factor applied in the Y direction.

Note that the grid lines will be shown taking into account the current Y scale, and the cells will therefor not, in general, be square. The scaling is also accounted for in the gradations computed for rulers that may be applied to the cross-section window.


next up previous contents index
Next: The Rulers Button: Create Up: The View Menu: Alter Previous: Layer Sequencing   Contents   Index
Stephen R. Whiteley 2017-10-02