next up previous contents index
Next: The Help Menu Up: The Assemble Button: Layout Previous: The File Menu   Contents   Index

The Options Menu

The Options menu contains buttons that enable making certain entries into the Merge Tool forms, and otherwise induce changes in configuration.

Reset
Pressing this button will reset the configuration of the Merge Tool to the startup (empty) configuration. All existing entries will be lost.

New Source
Each input file from which cells are to be extracted, termed a ``Source'', has a separate page in the Merge Tool display. At startup, there is one empty source page, which is specified as ``Source 1'' in the tab at the top of the display. The New Source button will create a new empty source page, with a new tab with a unique name. The new page will become the visible page. Other source pages can be selected by clicking on the tabs. Each source page must be filled in with the appropriate entries before a merge can be performed.

Remove Source
Pressing this button will irretrievably delete the currently visible source page, if it is not the initial ``Source 1'' page. The page and its tab and contents will disappear.

New Toplevel
This will add the name of a top level cell to the Top-Level Cells list of the current page. These are cells that represent the top level of hierarchies to be extracted from the archive file named in the Path to Source entry on the same page. The names in the list must match an actual cell name found in the file. These are ``top-level'' in the extraction sense and need not be top-level in the overall cell hierarchy of the file. The list can contain the same name multiple times if multiple instances of the cell are needed in output.

Note that the user must have knowledge of the names of the cells used in the file. The names specified must be the actual names found in the file, and do not reflect name changes that might be applied during processing.

Remove Toplevel
This will remove the highlighted entry in the Top-Level Cells list, if an entry is highlighted. An entry is highlighted by clicking on it with the mouse. When an entry is removed, it will not appear in the output.


next up previous contents index
Next: The Help Menu Up: The Assemble Button: Layout Previous: The File Menu   Contents   Index
Stephen R. Whiteley 2017-04-09