next up previous contents index
Next: Text Entry Windows Up: The WRspice User Interface Previous: Initial Operations   Contents   Index


The Tool Control Window

When the DISPLAY variable is found in the environment upon program startup, WRspice assumes that a graphical (X-window) server is available, and will enable its graphical components. If this initialization fails, WRspice will terminate. If the DISPLAY variable is not set, and the -d option is not used on the command line to specify the display, or the -dnone command line option is given, then WRspice will run in text-only mode. In this mode, the core functionality is available, but not the graphical niceties such as plotting (other than the infamous crude line-printer plots of yore). Under Microsoft Windows, graphics is (of course) always available.

When a graphical interface is available, WRspice by default provides a small Tool Control window which provides menus for controlling WRspice, and a display containing a tabulation of memory statistics. The menus contain buttons which bring up graphical screens, from which much most of WRspice can be controlled in a (perhaps) more user-friendly fashion. The locations of the pop-ups and their active/inactive status at program startup can be preset by the user.

When running WRspice through the Xic program, by default the Tool Control window will appear when connection to WRspice has been established. The Xic variable NoSpiceTools can be set, before the connection is established, to prevent the Tool Control window from appearing.

The text area lists the following quantities, though some may not be listed if the operating system does not provide this information. The listing is updated every few seconds. The first line of text shows the current running status of WRspice: idle, running, or stopped. Also shown on this line is the elapsed wall-clock time from the last status change. The time format is hours:minutes:seconds. The seconds entry has two decimal places (resolution is .01 second). The hours field is not included if zero. The user and system lines are similar, but display the total user cpu time used by the process, and the total system cpu time, respectively. The user time generally includes input/output processing time, where the system time is pure cpu usage. The data size entry displays the total allocated memory in Kb used by the program. This is only the memory allocated by the program for data, and does not include additional memory overhead reported by programs such as top and ps. This size is limited to the program limit, which is given in the following line. This limit can be changed with the maxdata variable. The final system limit line displays the maximum memory available from the system for the process.

WRspice supports the xdnd and Motif drag and drop protocols. One is able to drag files from many file manager programs into the Tool Control window of WRspice or the main window of Xic, and that file will be loaded into the program. The File Selection and Files Listing pop-ups participate in the protocols as sources and receivers. The text editor and mail pop-ups are drag receivers.

The file must be a standard file on the same machine. If it is from a tar file, or on a different machine, first drag it to the desktop or to a directory, then into WRspice. (Note: The GNOME gmc file manager allows one to view the contents of tar files, etc. as a ``virtual file system''. Window Maker and Enlightenment window managers, at least, are drag/drop aware.)

In the upper left of the Tool Control window is the WR button, which contains the Whiteley Research corporate logo. Pressing this button brings up a mail client (see 3.10), pre-loaded with the address of the Whiteley Research support staff. The text field containing the address, as well as the subject, can be changed. This can be used to send questions and bug reports to Whiteley Research, or to send messages or data files to colleagues.

To the right of the WR button are the Run (green arrow) and Stop (red X) buttons. Pressing the Run button is equivalent to giving the run command on the command line, without arguments. Pressing the Stop button issues an interrupt signal that will pause a simulation in progress, the same as if the user typed Ctrl-C in the console window.

To the right of the buttons is a menu bar with four entries: File, Edit, Tools, and Help. Pressing the mouse button 1 on these entries brings up a drop-down menu containing various commands.

The File menu contains commands for manipulating disk files.

File Select
Bring up a file manager panel. This panel allows files and directories to be created, deleted, and renamed, or read into WRspice. The file manager is described in 3.8.

Source
This button creates a dialog, soliciting a file to input into WRspice, as with the source command. When the dialog is active, the Tool Control text window is active as a drag receiver, so that file names can be dragged and dropped from compatible windows (such as the file manager), and the file name will be loaded into the dialog.

Load
This button is similar in operation to the Source button, however the file is expected to be a rawfile, which is the native plot-file format, or a Common Simulation Data Format (CSDF) file. Like the Source dialog, the Load dialog supports drag and drop protocols through the text area of the Tool Control window. The file is read and data are made available for analysis, similar to the load command.

Update Tools
The Update Tools button will save the current tool configuration, and the next time WRspice is started, the same tools will be available, in the same locations on-screen. The tools are available in the Tools menu to be described.

Initialization of the graphical interface is directed from the system init file wrspiceinit found in the startup directory, or more appropriately from the user's startup files (.wrspiceinit files) as found in the current or user's home directory. Only the file in the home directory can be automatically updated from within WRspice. A special command tbsetup, which is only recognized in these files, performs the initialization. The tbsetup function takes a long, messy command line, however fortunately the user has an easy way to automatically add this line, using the Update Tools command. This action is also available from the command line update command.

The Update Tools and update commands will create or update a .wrspiceinit file in the user's home directory. If the home directory can't be determined, the current directory will be used.

Update WRspice
The Update WRspice button will initiate a dialog on the command line to download a program update distribution file, and possibly install it over the present installation. Downloading/installation is only possible if a newer distribution exists on the Whiteley Research web site, and only if a current .wrpasswd file exists in the user's home directory, through use of the passwd command.

This button calls the wrupdate command (without arguments). The command-line wrupdate command provides a little more flexibility, such as the ability to download releases for other than the current ``operating system'' name. In either case, one can install the new release and continue running the present program, but subsequently starting WRspice will invoke the new version. The present executable is still available as ``wrspice.old''.

The computer must have http access to the internet for successful use of this functionality.

Quit
The Quit button will terminate the WRspice session, after confirmation if there is unsaved work. This can also be accomplished with the quit or exit command line functions.

The Edit menu contains commands used to modify input files.

Text Editor
This button brings up a text editor, similar to the edit command. The default text editor is described in 3.9, but the user can specify a different editor with the EDITOR or SPICE_EDITOR environment variables, or with the editor variable.

Xic
This button launches the Xic program, if it is available.

For schematic capture, the Xic program must be installed. When either editor is started, the currently loaded circuit, if any, and if it has graphical information in the case of Xic, is loaded into the editor. The simulation process can be initiated and controlled through Xic. The internal text editor has a Source button, which allows the modified circuit to be passed directly back to WRspice for simulation. If another editor is used, changes will have to be saved to disk and sourced from WRspice.

The Tools menu contains a configurable collection of command buttons which initiate pop-ups which control or display various aspects or WRspice. Each of these pop-ups is a graphical short cut to a collection of command line commands. Many users prefer the point-and-click interface to the command line, though some do not. With WRspice, the user has a choice. The command functions available in the Tools menu are listed below, in the order found in the menu.

Fonts
This brings up the Font Selection panel (see 3.11.1) that allows selection of the font used in the text areas of the various tools, and in plot windows used for displaying simulation results.

Files
Pop up the Path Files Listing panel (see 3.11.2) which displays a list of the files found along the sourcepath. Files can be sourced or edited through this panel.

Circuits
Bring up the Circuits panel (see 3.11.3) listing the circuits that are currently in memory. The panel provides capabilities for choosing the current circuit and deleting circuits from memory.

Plots
Bring up the Plots panel (see 3.11.4) which displays a list of the plots in memory. The panel provides capabilities for selecting the current plot, and for deleting plots.

Plot Opts
Bring up the Plot Options panel (see 3.11.5) to control the myriad of variables associated with plotting.

Colors
Bring up thePlot Colors panel (see 3.11.6) to set the colors used in the plots.

Vectors
Pop up the Vectors panel (see 3.11.7) listing the vectors in the current plot. The panel provides an interface for plotting or printing these vectors.

Variables
Pop up the Variables panel (see 3.11.8) displaying the shell variables currently set.

Shell
Bring up the Shell Options panel (see 3.11.9) used to control the default settings associated with the WRspice shell.

Sim Opts
Pop up the Simulation Options panel (see 3.11.10) used to modify the variables which affect circuit simulation.

Commands
Bring up the Command Options panel (see 3.11.11) to customize the variables associated with the various commands.

Trace
Pop up the Trace panel (see 3.11.12) which lists the ``debugs'' currently in effect. The ``debugs'' are directives to interactively plot, or trace variables during simulation, or to pause the simulation when a condition is met. The panel provides capability for deactivating or deleting ``debugs''.

Debug
Bring up the Debug Options panel (see 3.11.13) used to control the debugging modes of WRspice.

The Help menu provides entry into the help system, and provides access to other information. The buttons found in this menu are listed below.

Help
Bring up the help viewer loaded with the top-level page. The help system provides an extensive cross-referenced HTML database, and contains the latest information on WRspice features. The help system is described in 3.15.

About
Bring up a text window with the current WRspice version number, copyright, and legal disclaimer.

Notes
Bring up a text browser loaded with the release notes for the current release of WRspice. The release notes provide detailed information about changes in the present release, and serve as a supplement to the manual. Changes and new features should also have been incorporated into the help database.


next up previous contents index
Next: Text Entry Windows Up: The WRspice User Interface Previous: Initial Operations   Contents   Index
Stephen R. Whiteley 2017-10-02